<!doctype html>
<html>
    <head>
        <title>Key Marketing Metrics for Buyer Journey Conversions</title>
        <script type="text/javascript" src="//use.typekit.net/kkl1oja.js"></script>
        <script type="text/javascript">try{Typekit.load();}catch(e){}</script>
            <link rel="stylesheet" href="/content/themes/Marketo//themes/base/production/css/main.css?vzRh9qieJfc7DXiQLA1qMJA">
                    <meta name="viewport" content="width=device-width, initial-scale=1">
        
        <link rel="icon" type="image/png" sizes="96x96" href="https://blog.marketo.com/favicon.png">
<link rel="apple-touch-icon" sizes="180x180" href="https://blog.marketo.com/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="96x96" href="/favicon.png">
<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png">
<meta name="application-name" content="Marketo Blog" />
<meta name="msapplication-TileColor" content="#8C70C9" />
<meta name="msapplication-TileImage" content="https://blog.marketo.com/mstile-144x144.png" />
<meta name="msapplication-square70x70logo" content="https://blog.marketo.com/mstile-70x70.png" />
<meta name="msapplication-square150x150logo" content="https://blog.marketo.com/mstile-150x150.png" />
<meta name="msapplication-square310x310logo" content="https://blog.marketo.com/mstile-310x310.png" />

        <meta name="format-detection" content="telephone=no"/>
        
<!-- This site is optimized with the Yoast SEO plugin v6.3.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="What are the key marketing metrics for buyer journey conversions? Linear buyer journeys rarely take place. The path for each contact to make it through to the ultimate decision to purchase your goods or services is rarely the same. Patrick Groover discusses how to measure buyer journey velocity and more."/>
<link rel="canonical" href="https://blog.marketo.com/2018/03/key-marketing-metrics-buyer-journey-conversions.html" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Key Marketing Metrics for Buyer Journey Conversions" />
<meta property="og:description" content="What are the key marketing metrics for buyer journey conversions? Linear buyer journeys rarely take place. The path for each contact to make it through to the ultimate decision to purchase your goods or services is rarely the same. Patrick Groover discusses how to measure buyer journey velocity and more." />
<meta property="og:url" content="https://blog.marketo.com/2018/03/key-marketing-metrics-buyer-journey-conversions.html" />
<meta property="og:site_name" content="Marketo Marketing Blog - Best Practices and Thought Leadership" />
<meta property="article:tag" content="b2b" />
<meta property="article:tag" content="Consumer" />
<meta property="article:section" content="Marketing Metrics" />
<meta property="article:published_time" content="2018-03-05T08:19:38-08:00" />
<meta property="og:image" content="https://blog.marketo.com/content/uploads/2018/03/GettyImages-518311294.jpg" />
<meta property="og:image:secure_url" content="https://blog.marketo.com/content/uploads/2018/03/GettyImages-518311294.jpg" />
<meta property="og:image:width" content="2449" />
<meta property="og:image:height" content="1224" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Marketo Marketing Blog - Best Practices and Thought Leadership &raquo; Key Marketing Metrics for Buyer Journey Conversions Comments Feed" href="https://blog.marketo.com/2018/03/key-marketing-metrics-buyer-journey-conversions.html/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blog.marketo.com\/wp\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='swiftype-css'  href='https://blog.marketo.com/content/plugins/swiftype-search/assets/autocomplete.css?ver=4.7.2' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var swiftypeParams = {"engineKey":"cQGhe2xja7Zb4dufFRug"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blog.marketo.com/content/plugins/swiftype-search/assets/install_swiftype.min.js?ver=4.7.2'></script>
<link rel='https://api.w.org/' href='https://blog.marketo.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blog.marketo.com/wp/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://blog.marketo.com/wp/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.7.2" />
<link rel='shortlink' href='https://blog.marketo.com/?p=68956' />
<link rel="alternate" type="application/json+oembed" href="https://blog.marketo.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.marketo.com%2F2018%2F03%2Fkey-marketing-metrics-buyer-journey-conversions.html" />
<link rel="alternate" type="text/xml+oembed" href="https://blog.marketo.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.marketo.com%2F2018%2F03%2Fkey-marketing-metrics-buyer-journey-conversions.html&#038;format=xml" />

            </head>
<body class="BlogPage">
<!-- Google Tag Manager -->
<script type="text/javascript">var _gaq = _gaq || [], dataLayer = dataLayer || [];function tagLinkEvent(name){dataLayer.push({event:name});}</script>
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-Z8LR" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-Z8LR');</script>
<!-- End Google Tag Manager -->
<div class="hide"></div><!-- End Quantcast Tag -->
<header id="SiteHeader" class="site-header" role="banner">
    <div class="container">
        <div class="site-header__inner">
            <a href="https://www.marketo.com/" target="_blank" rel="noopener noreferrer" class="site-header__logo">
                <img src="https://blog.marketo.com/content/themes/Marketo/themes/base/production/images/marketo-logo.png" alt="Marketo.com">
            </a>
            <section class="site-header-icon-wrapper">
                                <div class="site-header-icon-container
                                            header-link--active
                                     ">
                    <a href="https://blog.marketo.com">
                        <div class="site-header__icon site-header__icon--blog"></div>
                    </a>
                </div>
                <div class=" site-header-icon-container
                                            header-link--inactive
                                     ">
                    <a href="https://cmo.marketo.com">
                        <div class="site-header__icon site-header__icon--cmo"></div>
                    </a>
                </div>
            </section>

            <div id="SearchFormContainer" class="site-header__search">
                    <form action="https://blog.marketo.com/" method="get" id="SearchForm" class="search-form" role="search" novalidate>
    <label class="sr-only" for="SearchForm__Field">Search for:</label>
    <input type="search" id="SearchForm__Field" name="s" class="search-form__field" placeholder="Blog Search">
    <button id="SearchForm__Submit" class="search-form__submit" type="submit">
        <span class="sr-only">Search</span>
        <img src="https://blog.marketo.com/content/themes/Marketo/themes/base/production/images/icon-search.png" alt="Search" width="23.5" height="24">
    </button>
</form>            </div>

            <div class="site-header__nav">
                <div class="site-header__nav__menu NavToggle">
                    <span></span>
                    <span></span>
                    <span></span>
                </div>
                <nav id="SiteNav" class="site-nav" role="navigation">
    <div class="site-nav__title">Blog Menu</div>

    <div class="site-nav__list-container">
        <ul>
                                                <li>
                        <a href="https://blog.marketo.com/category/account-based-marketing">Account-Based Marketing</a>
                    </li>
                                                                <li>
                        <a href="https://blog.marketo.com/category/branding">Branding</a>
                    </li>
                                                                <li>
                        <a href="https://blog.marketo.com/category/content-marketing">Content Marketing</a>
                    </li>
                                                                <li>
                        <a href="https://blog.marketo.com/category/customer-marketing">Customer Marketing</a>
                    </li>
                                                                <li>
                        <a href="https://blog.marketo.com/category/demand-generation">Demand Generation</a>
                    </li>
                                                                <li>
                        <a href="https://blog.marketo.com/category/digital-marketing">Digital Marketing</a>
                    </li>
                                                                <li>
                        <a href="https://blog.marketo.com/category/email-marketing">Email Marketing</a>
                    </li>
                                                                <li>
                        <a href="https://blog.marketo.com/category/engagement-marketing">Engagement Marketing</a>
                    </li>
                                                                <li>
                        <a href="https://blog.marketo.com/category/event-marketing">Event Marketing</a>
                    </li>
                                                                <li>
                        <a href="https://blog.marketo.com/category/infographic">Infographic</a>
                    </li>
                                                                <li>
                        <a href="https://blog.marketo.com/category/lead-management">Lead Management</a>
                    </li>
                                                                <li>
                        <a href="https://blog.marketo.com/category/lifecycle-marketing">Lifecycle Marketing</a>
                    </li>
                                                                <li>
                        <a href="https://blog.marketo.com/category/marketing-automation">Marketing Automation</a>
                    </li>
                                                                <li>
                        <a href="https://blog.marketo.com/category/budgets">Marketing Budget</a>
                    </li>
                                                                <li>
                        <a href="https://blog.marketo.com/category/marketing-metrics">Marketing Metrics</a>
                    </li>
                                                                <li>
                        <a href="https://blog.marketo.com/category/marketing-technology">Marketing Technology</a>
                    </li>
                                                                <li>
                        <a href="https://blog.marketo.com/category/mobile-marketing">Mobile Marketing</a>
                    </li>
                                                                                            <li>
                        <a href="https://blog.marketo.com/category/modern-marketing">Modern Marketing</a>
                    </li>
                                                                <li>
                        <a href="https://blog.marketo.com/category/nurturing">Nurturing</a>
                    </li>
                                                                <li>
                        <a href="https://blog.marketo.com/category/product-and-industry">Product and Industry</a>
                    </li>
                                                                <li>
                        <a href="https://blog.marketo.com/category/professional-development">Professional Development</a>
                    </li>
                                                                <li>
                        <a href="https://blog.marketo.com/category/sales">Sales</a>
                    </li>
                                                                <li>
                        <a href="https://blog.marketo.com/category/sales-marketing-alignment">Sales Marketing Alignment</a>
                    </li>
                                                                <li>
                        <a href="https://blog.marketo.com/category/scoring">Scoring</a>
                    </li>
                                                                <li>
                        <a href="https://blog.marketo.com/category/search-engine-optimization">Search Engine Optimization</a>
                    </li>
                                                                <li>
                        <a href="https://blog.marketo.com/category/social-media-marketing">Social Media Marketing</a>
                    </li>
                                                                <li>
                        <a href="https://blog.marketo.com/category/targeting-and-personalization">Targeting and Personalization</a>
                    </li>
                                                                <li>
                        <a href="https://blog.marketo.com/category/testing-and-optimization">Testing and Optimization</a>
                    </li>
                                                                </ul>

            </div>
</nav>
            </div>
        </div>
    </div>
</header>

<main class="site-main" role="main">
    <div class="container">
            <div id="InfiniteScroll__Container">
        <article class="blog-post-page InfiniteScroll__Section" data-url="https://blog.marketo.com/2018/03/key-marketing-metrics-buyer-journey-conversions.html" data-disqus-id="68956 http://blog.marketo.com/?p=68956">
    <div class="blog-post-page__header" style="background-image: url(https://blog.marketo.com/content/uploads/2018/03/GettyImages-518311294-2560x700-c-default.jpg);">
        <h2><a href="https://blog.marketo.com/category/marketing-metrics">Marketing Metrics</a></h2>
        <h1>Key Marketing Metrics for Buyer Journey Conversions</h1>
    </div>

    <div class="grid-box grid-box--gutter-0">
        <div class="col col--blog-post-main">
            <div class="blog-post-page__main">
                <div class="blog-post-social-media">
    <div class="blog-post-social-media__share-count">
        <span class="blog-post-social-media__share-count__count">1.8k</span>
        <span class="blog-post-social-media__share-count__shares">Shares</span>
    </div>

    <div class="blog-post-social-media__social-links">
        <ul class="social-media-links">
            <li>
                <a
                    href="https://www.facebook.com/sharer.php?u=https://blog.marketo.com/2018/03/key-marketing-metrics-buyer-journey-conversions.html"
                    target="_blank"
                    class="social-media-link--facebook"
                    rel="noopener noreferrer"
                    title="Facebook"
                    onclick="window.open(this.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,width=600,height=450');return false;"
                >
                    <i class="fa fa-facebook-square"></i>
                    <span>Share</span>
                </a>
            </li>

            <li>
                <a
                    href="https://twitter.com/share?url=https://blog.marketo.com/2018/03/key-marketing-metrics-buyer-journey-conversions.html&amp;text=As marketers we can get caught up in all of the nuances of specific campaigns, emails opened, calls-to-action clicked, forms&hellip;"
                    target="_blank"
                    class="social-media-link--twitter twitter-link"
                    rel="noopener noreferrer"
                    title="Twitter"
                    onclick="window.open(this.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,width=600,height=450');return false;"
                >
                    <i class="fa fa-twitter"></i>
                    <span>Share</span>
                </a>
            </li>

            <li>
                <a
                    href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://blog.marketo.com/2018/03/key-marketing-metrics-buyer-journey-conversions.html"
                    target="_blank"
                    class="social-media-link--linkedin"
                    rel="noopener noreferrer"
                    title="Linkedin"
                    onclick="window.open(this.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,width=600,height=450');return false;"
                >
                    <i class="fa fa-linkedin-square"></i>
                    <span>Share</span>
                </a>
            </li>
        </ul>
    </div>
</div>
                <div class="blog-post-page__content">
                                                                        <div class="blog-post-page__author">
                                                                    <a href="https://blog.marketo.com/author/patrick-groover" class="blog-post-page__author__img" rel="author">
                                        <img src="https://blog.marketo.com/content/uploads/2017/05/532-200x200-c-default.jpeg" alt="Patrick Groover">
                                    </a>
                                
                                <span class="blog-post-page__author__name">
                                    By:
                                    <a href="https://blog.marketo.com/author/patrick-groover" rel="author">
                                                                                    Patrick Groover
                                                                            </a>
                                </span>

                                
                                                            </div>
                                            
                    <div class="blog-post-page__content__text">
                        <p>As marketers we can get caught up in all of the nuances of specific campaigns, emails opened, calls-to-action clicked, forms filled out, events attended, and more. The challenge is that at times we may not be seeing the forest for the trees. While numerous potential measurements exist, some key marketing metrics can help guide results across your strategy.</p>
<p><strong><u>In this blog, we’ll take a look at one of those metrics: buyer journey conversions. I’ll cover the details surrounding the purpose, application, technology and benchmarking you can use to develop this key marketing metric.</u></strong></p>
<p>Let’s step back for a minute and consider that linear <a href="http://blog.marketo.com/2016/02/take-to-the-open-road-reduce-rework-and-automate-the-buyer-journey-without-flowcharts.html" target="_blank">buyer journeys</a> rarely take place. The path for each contact to make it through to the ultimate decision to purchase your goods or services is rarely the same. For example, one customer may review information on your website, read a reminder email, talk to your sales team, then work with your sales team to begin evaluating what you have to offer. Another customer may <a href="http://blog.marketo.com/2018/02/5-ways-increase-event-engagement.html" target="_blank">attend an event</a>, fill out a “contact me” form, receive a follow-up email, browse your site, and finally receive a call back from your sales team that converts them to an opportunity.</p>
<p>Both examples show forward progress towards the same outcome, though each took a very different route.</p>
<p>As a marketing consultant, I am consistently asked: “how do we see what path is optimal for getting customers to move forward in their buying journey?” While I do agree that it is very valuable to understand what content and campaigns are making the most impact on customers within the buying journey, I think we can all agree that buying journeys are mostly unique. As a result, we need a <a href="http://blog.marketo.com/2018/02/cut-key-marketing-metrics-mess.html" target="_blank">key marketing metric</a> to help measure performance across the journey even when individuals take unique paths.</p>
<h2>Buyer Journey Velocity Defined</h2>
<p>How, then, do we track progress toward an ultimate outcome and how do we align the optimal communication to reach audiences where they are at within their journey?</p>
<p>The answer is a flexible approach to journey tracking with tools that measure forward progress of contacts and that allow you to compare journey status to campaign and communications impact.  The key marketing metric I am referring to is buyer journey velocity or <a href="http://blog.marketo.com/2017/11/sales-velocity-critical-sales-metric-team-probably-isnt-measuring.html" target="_blank">funnel velocity</a>, measured by comparing time in buying stage to amount and types of content consumed.</p>
<p>Buyer journey velocity can help you detect where bottlenecks exist within your sales and marketing process. It can determine overall campaign effectiveness across communications efforts and within target <a href="http://blog.marketo.com/2017/12/5-factors-consider-segmenting-customers.html" target="_blank">segments</a>, helping your team optimize the marketing mix. Funnel velocity enables you to identify strengths and weaknesses within your approach so that targeted improvements can be made to keep people moving towards a purchase.</p>
<p>With the power to uncover impact across your marketing approach, buyer journey velocity is a key marketing metric.</p>
<h2>Getting Started With Buyer Journey Tracking</h2>
<p>The first step to getting this key marketing metric set up is to identify the standard stages of your typical buyer journey, both pre- and post-sale.  Leverage previous knowledge of wins, identify effective marketing campaigns, and work with your sales team to define the stages that make the most sense for your company. Start with a general <a href="http://blog.marketo.com/2016/06/guide-your-buyers-through-the-customer-journey-with-social-media.html" target="_blank">buyer journey</a> and create more specific journeys over time if it becomes apparent that certain industries or audiences need their own tracking.  Most companies can identify a central journey for standard products and product lines to start.</p>
<p>Let’s take a look at a standard buyer journey and review some basic marketing scenarios to uncover how buyer journey velocity can help identify where we see optimal marketing results.</p>
<p>&nbsp;</p>
<p><img class="alignnone size-full wp-image-68957 aligncenter" src="https://blog.marketo.com/content/uploads/2018/03/Buyer-Journey-Example.png" alt="Buyer Journey Example" width="974" height="356" srcset="https://blog.marketo.com/content/uploads/2018/03/Buyer-Journey-Example.png 974w, https://blog.marketo.com/content/uploads/2018/03/Buyer-Journey-Example-300x110.png 300w, https://blog.marketo.com/content/uploads/2018/03/Buyer-Journey-Example-768x281.png 768w" sizes="(max-width: 974px) 100vw, 974px" /></p>
<p>As seen in the figure above, marketers must first define the stages that match the typical flow of customers towards their desired outcome. It is also possible to monitor progress after achieving an initial objective, for example, once a prospect converts to a customer, it is possible to then measure repeat purchases and even customer advocacy. Teams can then measure more than just customer acquisition, it is possible to monitor the nurturing of existing relationships and the building of lifetime customer value (LTV).</p>
<p>Once stages are identified, campaigns and <a href="http://blog.marketo.com/2016/07/content-with-a-purpose-5-tips-to-map-your-content-to-the-buyers-journey.html" target="_blank">content</a> should be developed to target conversions within the specific stages. What will become apparent after monitoring results is that content can often have residual or adjacent impact to the target outcome. In other words, content and campaigns developed for one purpose may often time be impacting multiple stages within the buyer journey or even making a more significant impact within stages other than the initially intended goal.</p>
<h2>Benchmarking to Define a Baseline</h2>
<p>Part of leveraging key marketing metrics such as the buyer journey velocity is initial tracking of results. To do this, it is important to establish benchmarks through previous results. Buyer journey velocity is somewhat of an industry and even company-specific metric so it will be essential to collaborate with marketing peers in other companies to establish initial baselines.</p>
<p>When defining benchmarks, it is vital to properly identify conversion criteria that tightly match the definition for progressing forward into the next stage of the buyer journey. Having access to the right platform will provide the flexibility needed to define conversion criteria with an appropriate level of specificity. This could include specific digital actions (i.e., pages visited, <a href="http://blog.marketo.com/2017/11/7-tech-trends-email-marketers.html" target="_blank">emails opened</a>), targeted interactions (i.e., with sales), score-based thresholds (i.e., score achieved), or data points collected, and even a combination of all of the above.</p>
<p>With an appropriate buyer journey defined and with realistic criteria for measuring progress, it is time to capture customer interactions and results for a test period. The initial testing period will depend upon your typical journey lifecycle, though two to three months of starting information will help the marketing team get a starting idea of what is taking place within campaigns. Data from the buyer journey can then identify the areas of the journey that appear to be taking longer than others.</p>
<h2>Evaluating Buyer Journey Velocity</h2>
<p>The core focus of this key marketing metric is to help the marketing team identify the average pace that audiences are flowing through towards your desired marketing outcome. Comparing the time in stage, touches per stage, and types of interactions can reveal a world of knowledge about campaign contributions. By starting at the stage level, marketers can compare the rate of conversion to any number of marketing dimensions, helping highlight then identify contributions that are working, need to be improved, or that can be eliminated from the marketing mix.</p>
<p>Marketers can then identify <a href="http://blog.marketo.com/2017/05/1-awesome-way-create-great-content.html" target="_blank">high performing content</a>, best locations for content consumption, and opportunities to eliminate low performing marketing expenses. Cross-referencing the stage, the time in stage, and the number of program successes occurring within each stage can help the marketing team begin to identify the landscape of interactions that are making an impact, taking longer than expected, or not making any impact.</p>
<p>Here are a few useful comparisons and reports to consider:</p>
<ul>
<li>Average time in stage</li>
<li>Campaign contributions by stage</li>
<li>Channel contributions by stage</li>
<li>Last touch by stage</li>
<li>Audience type (i.e., industry or role) by time in stage</li>
</ul>
<p>While simple comparisons, these <a href="http://blog.marketo.com/2018/02/key-marketing-metrics-matter-website.html" target="_blank">key marketing metrics</a> can shed light on performance, identify gaps in follow-up and optimize marketing communications investments.  Content and campaigns that are making the most impact can shed light on additional opportunities for results.</p>
<p>A final comparative value that is closely related to buyer journey velocity is the number of touches needed to deliver a stage-level conversion. As shown in the calculation below, it is important to reflect on the amount of investment going into the forward velocity, not just the speed of conversions. Marketing is a balance between effort (investment) and results, so it is important to determine how many touches are needed to drive the outcome.</p>
<h2>Average Touches per Stage Level Conversion</h2>
<p>When comparing effort to results, benchmarking is equally important to determine if programs represent the optimal marketing mix.  If the buyer journey is taking longer than expected, identify potential touches within the journey that may have delayed a result, or that might have been routed directly to a different customer interaction. This can apply to sales touches, not only marketing touches.</p>
<h2>Closing Thoughts</h2>
<p>While this is a brief overview of the value and use of buyer journey velocity as a key marketing metric, there is an enormous amount of opportunity for marketers to leverage this measurement. Getting started with the steps listed above will help your team define the best practice journey that matches your audience and objectives. Over time, with a buyer journey in place and initial tracking of both velocity and touches per conversion your marketing team can begin optimizing performance towards greater and greater efficiency.</p>
<p>As a final note, buyer journey velocity has tremendous application to <a href="http://blog.marketo.com/2018/02/abm-key-marketing-metrics-track-every-stage-funnel.html" target="_blank">account-based marketing</a>.  Comparing overall account-level velocity can provide insights into the total impact of marketing campaigns on driving revenue results.</p>
<p>I would enjoy hearing your thoughts and comments below as well as ways that you have used buyer journey velocity as a key marketing metric to optimize your campaigns and overall customer engagement.</p>

                    </div>
                                        <div class="newsletter-form-container newsletter-form-container--blog-post">
                            <form id="mktoForm_5691" class="newsletter-form-container__newsletter-form initial-form-hide"></form>

    <div class="newsletter-form-container__success-message">
        <p>Thanks For Subscribing!</p>
    </div>
                    </div>
                                                                                    
<div id="disqus_thread">
    </div>

<script type="text/javascript">
var disqus_url = 'https://blog.marketo.com/2018/03/key-marketing-metrics-buyer-journey-conversions.html';
var disqus_identifier = '68956 http://blog.marketo.com/?p=68956';
var disqus_container_id = 'disqus_thread';
var disqus_shortname = 'marketo-blogs';
var disqus_title = "Key Marketing Metrics for Buyer Journey Conversions";
var disqus_config_custom = window.disqus_config;
var disqus_config = function () {
    /*
    All currently supported events:
    onReady: fires when everything is ready,
    onNewComment: fires when a new comment is posted,
    onIdentify: fires when user is authenticated
    */
    
    
    this.language = '';
    
    if (disqus_config_custom) {
        disqus_config_custom.call(this);
    }
};

(function() {
    var dsq = document.createElement('script'); dsq.type = 'text/javascript';
    dsq.async = true;
    dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
})();
</script>


                                    </div>
            </div>
        </div>

        <div class="col col--blog-post-sidebar hidden--xs">
            <div class="blog-post-page__sidebar">
                                    <a href="https://blog.marketo.com/2018/02/abm-key-marketing-metrics-track-every-stage-funnel.html" class="blog-post-preview">
    <div class="blog-post-preview__img" style="background-image: url('https://blog.marketo.com/content/uploads/2018/02/GettyImages-627013410-600x400-c-default.jpg')"></div>
    <div class="blog-post-preview__text">
        <div class="blog-post-preview__text__inner">
            <h3>Marketing Metrics</h3>
            <p>ABM Key Marketing Metrics to Track at Every Stage of the Funnel</p>
                            <span class="hidden--xs">By:
                                                                        Lizzy Funk<br>
                        
                        
                        
                                                            </span>
            
        </div>
    </div>
</a>                                    <a href="https://blog.marketo.com/2018/02/key-marketing-metrics-matter-website.html" class="blog-post-preview">
    <div class="blog-post-preview__img" style="background-image: url('https://blog.marketo.com/content/uploads/2018/02/GettyImages-567354107-600x400-c-default.jpg')"></div>
    <div class="blog-post-preview__text">
        <div class="blog-post-preview__text__inner">
            <h3>Marketing Metrics</h3>
            <p>What Key Marketing Metrics Matter for Your Website?</p>
                            <span class="hidden--xs">By:
                                                                        Favian Castillo<br>
                        
                        
                        
                                                            </span>
            
        </div>
    </div>
</a>                                    <a href="https://blog.marketo.com/2018/02/cut-key-marketing-metrics-mess.html" class="blog-post-preview">
    <div class="blog-post-preview__img" style="background-image: url('https://blog.marketo.com/content/uploads/2018/02/GettyImages-730274891-600x400-c-default.jpg')"></div>
    <div class="blog-post-preview__text">
        <div class="blog-post-preview__text__inner">
            <h3>Marketing Metrics</h3>
            <p>How to Cut Through the Key Marketing Metrics Mess</p>
                            <span class="hidden--xs">By:
                                                                        Katie Pedroza<br>
                        
                        
                        
                                                            </span>
            
        </div>
    </div>
</a>                
                <div class="promotion-tile">
    <a href="" target="_blank" rel="noopener noreferrer">
        <img src="" alt="">
    </a>
</div>
            </div>
        </div>
    </div>

                <div id="InfiniteScroll__Pagination" class="blog-main__pagination">
            <a href="https://blog.marketo.com/2018/02/abm-key-marketing-metrics-track-every-stage-funnel.html" class="blog-main__pagination__next" data-ajax-href="https://blog.marketo.com/2018/02/abm-key-marketing-metrics-track-every-stage-funnel.html?ajax=1">https://blog.marketo.com/2018/02/abm-key-marketing-metrics-track-every-stage-funnel.html</a>
        </div>
    </article>    </div>
    </div>
</main>

                <script type="text/javascript">
        // <![CDATA[
        var disqus_shortname = 'marketo-blogs';
        (function () {
            var nodes = document.getElementsByTagName('span');
            for (var i = 0, url; i < nodes.length; i++) {
                if (nodes[i].className.indexOf('dsq-postid') != -1) {
                    nodes[i].parentNode.setAttribute('data-disqus-identifier', nodes[i].getAttribute('data-dsqidentifier'));
                    url = nodes[i].parentNode.href.split('#', 1);
                    if (url.length == 1) { url = url[0]; }
                    else { url = url[1]; }
                    nodes[i].parentNode.href = url + '#disqus_thread';
                }
            }
            var s = document.createElement('script');
            s.async = true;
            s.type = 'text/javascript';
            s.src = '//' + disqus_shortname + '.disqus.com/count.js';
            (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
        }());
        // ]]>
        </script>
        <script type='text/javascript' src='https://blog.marketo.com/wp/wp-includes/js/wp-embed.min.js?ver=4.7.2'></script>
<!-- Schema App --><script type="application/ld+json">{"@context":"http:\/\/schema.org\/","@type":"BlogPosting","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/blog.marketo.com\/2018\/03\/key-marketing-metrics-buyer-journey-conversions.html"},"headline":"Key Marketing Metrics for Buyer Journey Conversions","name":"Key Marketing Metrics for Buyer Journey Conversions","description":"As marketers we can get caught up in all of the nuances of specific campaigns, emails opened, calls-to-action clicked, forms filled out, events attended, and more. The challenge is that at times we may not be seeing the forest for the trees. While numerous potential measurements exist, some key marketing metrics can help guide results [&hellip;]","datePublished":"2018-03-05","dateModified":"2018-03-05","author":{"@type":"Person","name":"kniemisto","url":"https:\/\/blog.marketo.com\/users\/kniemisto","image":{"@type":"ImageObject","url":"https:\/\/secure.gravatar.com\/avatar\/a9880bdb956d0f2321296d40dbbea5d3?s=96&d=identicon&r=g","height":96,"width":96}},"publisher":{"@type":"Organization","name":"Marketo","logo":{"@type":"ImageObject","url":"http:\/\/blog.marketo.com\/wp-content\/uploads\/2016\/12\/Marketo-Logo-Large.jpg","width":466,"height":287}},"image":{"@type":"ImageObject","url":"https:\/\/blog.marketo.com\/content\/uploads\/2018\/03\/GettyImages-518311294.jpg","height":1224,"width":2449},"url":"https:\/\/blog.marketo.com\/2018\/03\/key-marketing-metrics-buyer-journey-conversions.html","about":["Marketing Metrics"],"wordCount":1688,"keywords":["b2b","Consumer"],"commentCount":"0"}</script><!-- Schema App -->


<script src="https://ajax.googleapis.com/ajax/libs/jquery/2.1.1/jquery.min.js"></script>
<script src="https://blog.marketo.com/content/themes/Marketo/themes/base/source/js/modules/jquery-ias.min.js"></script>
<script type="text/javascript" src="//micro.marketo.com/common/location/"></script>
<script src="//app-ab13.marketo.com/js/forms2/js/forms2.min.js"></script>
<script src="https://blog.marketo.com/content/themes/Marketo/themes/base/source/js/includes/marketo-forms-helper.min.js"></script>

<script type="text/javascript">
    // Load Lead Data API.

    var _mkl = window._mkl || [];
    _mkl.push(['_setConnectorURL', '/common/toolkit/connector']);
    _mkl.push(['_setAdditionalFields', 'Country,CASLOptIn,Blog_subscriber']);
    _mkl.push(['_onRegisterFields', function (Lead) {
        var data = Lead.data();

        // A first time subscriber's data is pulled directly from the API where the 'Blog_subscriber' data is stored
        // as a bool, on a second load, the data is pulled from a cookie and is stored as a string. Check for both.
        if (!data.Blog_subscriber || data.Blog_subscriber === "false") {
            MktoForms2.whenReady(function (form) {
                $('#mktoForm_5691').removeClass('initial-form-hide');
            });
        }
    }]);
    (function() {
        var ml = document.createElement('script'); ml.type = 'text/javascript'; ml.async = true;
        ml.src = '/common/toolkit/static/lead.js';
        var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ml, s);
    })();

    MktoForms2.whenReady(function (form) {
        var formElem = form.getFormElem();

        // On success give a thank you message
        form.onSuccess(function () {
            var successMessage = formElem.next('.newsletter-form-container__success-message');

            formElem.hide();

            if (successMessage.length) {
                successMessage.show();
                tagLinkEvent('Blog - Subscribe');
            }

            return false;
        });
    });

    // Infinite scroll plugin
    var ias = $.ias({
        container: '#InfiniteScroll__Container',
        item: '.InfiniteScroll__Section',
        pagination: '#InfiniteScroll__Pagination',
        next: 'a.blog-main__pagination__next',
    });

    
    ias.extension(new IASSpinnerExtension({
        html: '<div class="ias-preloader"><i class="fa fa-refresh fa-spin"></i><br><span>Loading ...</span></div>',
    }));
    ias.extension(new IASTriggerExtension({offset: 100}));
    ias.extension(new IASPagingExtension());
    ias.extension(new IASHistoryExtension({prev: 'a.blog-main__pagination__prev'}));

    // Add AJAX string to url if on the Blog Page
    if ($('body').hasClass('BlogPage')) {
        ias.on('load', function (event) {
            event.url = event.url + '?ajax=1';
        });
    }

    // Before the next page has loaded
    ias.on('next', function (url) {
        // Send analytics
        ga('set', 'page', url);
        ga('send', 'pageview');
    });

    ias.on('rendered', function (items) {
        // Copy the Marketo form onto new pages
        $(items).find('.newsletter-form-container form')
            .replaceWith($('.newsletter-form-container form').first().clone(true));
    });

    ias.on('pageChange', function (pageNum, scrollOffset, url) {
        let prevPageNum = window.previousPageNum;
        if (prevPageNum !== pageNum) {
            window.previousPageNum = pageNum;
            // Prevent jitter if scrolling up
            if (pageNum === prevPageNum - 1) {
                return;
            }
        }
        // Move Disqus after the next page is loaded
        let currentContent = document.getElementsByClassName('blog-post-page__content')[pageNum - 2];
        if (currentContent) {
            let currentContainer = document.getElementsByClassName('InfiniteScroll__Section')[pageNum - 2];
            // Don't move Disqus to the same place
            if (disqus_identifier !== currentContainer.getAttribute('data-disqus-id')) {
                currentContent.appendChild(document.getElementById('disqus_thread'));
                // Update ID and reload
                disqus_url = currentContainer.getAttribute('data-url');
                disqus_identifier = currentContainer.getAttribute('data-disqus-id');
                DISQUS.reset({
                    reload: true,
                    config: function () {
                        this.page.identifier = currentContainer.getAttribute('data-disqus-id');
                        this.page.url = currentContainer.getAttribute('data-url');
                    },
                });
            }
        }
    });
</script>

<script>
    //Load populate.js
    (function() {
        var ml = document.createElement('script'); ml.type = 'text/javascript'; ml.async = true;
        ml.src = '/common/toolkit/static/populate.js?2015-07-22-1130';
        var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ml, s);
    })();
</script>

    <script src="/content/themes/Marketo//themes/base/production/js/main.js?v66NcbvMjA1ln4uqxbjnkUw"></script>

<script type="text/javascript">
  tagLinkEvent('callAutoTracker');
  tagLinkEvent('site:blog');
</script>
</body>
</html>
